We are currently experiencing issues with www.klarna.com
Incident Report for Klarna
Resolved
The issue has now been fixed.
Posted Jan 31, 2020 - 07:54 CET
Investigating
We are currently experiencing partial outage of www.klarna.com where some pages aren't loading. We are working as fast as possible to get the pages restored.
Posted Jan 30, 2020 - 23:41 CET