Multiple payment methods in Europe has intermittent degradation since 13:58
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 11, 2022 - 15:33 CEST
Investigating
We are currently experiencing intermittent degradation of multiple payments since 13:58 in Europe. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 11, 2022 - 14:29 CEST
This incident affected: Purchase API (Europe).