Klarna Card and Card Admin Service degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 23:53 CEST
Identified
The issues have been identified by our 3rd party provider. We see some recovery and continue monitoring this closely.
Posted Jun 17, 2022 - 23:37 CEST
Update
The Cards Admin Service is also showing degradation. We are working to restore the service as soon as possible.
Posted Jun 17, 2022 - 22:15 CEST
Investigating
We are currently experiencing a degradation of Klarna Card and Klarna Debit Card. Impacting Sign-Up, Card Purchases in the whole of EU. Consumers might be unable to purchase using a card or sign up for a new card. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jun 17, 2022 - 21:24 CEST
This incident affected: Klarna Card (Europe) and Merchant Operations (Europe).