New debts are not visible in the Klarna app EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 12:34 CEST
Identified
Due to an internal issue, new debts are not visible to users. We have identified the cause and currently implementing the fix.
Posted Jul 12, 2021 - 11:39 CEST
This incident affected: Klarna App.