Consumers in Germany unable to sign up for Klarna Card
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Dec 06, 2020 - 18:10 CET
Investigating
Consumers in Germany are currently unable to sign up for a Klarna Card due to a failure in digital contract signing managed by a third party. Signing up can still be completed using video identification and the third party has been contacted. We apologise for the inconvenience caused.
Posted Dec 06, 2020 - 16:33 CET
This incident affected: Klarna Card.