Klarna Payment Issue for H&M in Switzerland
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologise for the inconvenience caused. If you encounter any further trouble in relation to {Klarna Payments, please reach out to us for help by using the Klarna app.
Posted Oct 11, 2019 - 19:16 CEST
Update
The following updates pertain to this incident:

* Rolling back to last stable state


We will share our next update at19:00 CEST. We thank you for your patience and apologise for the inconvenience caused.
Posted Oct 11, 2019 - 18:19 CEST
Investigating
Customers in Switzerland are currently experiencing difficulties loading Klarna Payments since 14:00 today for H&M. Our engineers are investigating the issue and we apologies for the inconvenience caused. We will provide further updates as soon as possible.
Posted Oct 11, 2019 - 17:46 CEST
This incident affected: Klarna Payments (KP) Frontend.