Chat service currently unavailable for Finnish customers
Incident Report for Klarna
Resolved
Since about 18:30 CEST, the security incident has been resolved.
Posted 2 months ago. Jul 07, 2019 - 22:13 CEST
Investigating
Due to physical security related circumstances, the Finish chat team can't access their workspace and therefore had to close down the chat service.
We will keep you informed.
Posted 2 months ago. Jul 07, 2019 - 15:20 CEST