Authentication for US consumers not working as expected
Incident Report for Klarna
Resolved
Everything works as intended again. The incident is resolved.
Posted Mar 19, 2020 - 21:26 CET
Investigating
Authentication for US consumers is not working as expected for around 2 hours, but they are still able to complete their purchases.
Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Mar 19, 2020 - 21:03 CET
This incident affected: Klarna Payments (KP) Backend.