Consumers using ING bank in the Netherlands are unable to initiate direct bank transfers through the iDEAL platform due to ING service unavailability.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 21, 2021 - 08:33 CET
Identified
We are currently monitoring the situation.
Posted Mar 21, 2021 - 03:07 CET