Klarna website is currently down in Australia
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 15:31 CEST
Update
The technical teams have confirmed that there is no impact on Klarna Check Out or Klarna Payment methods due to this issue.
Posted Apr 22, 2021 - 15:14 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 22, 2021 - 15:07 CEST
This incident affected: Klarna Website.