US Chat is currently experiencing outages
Incident Report for Klarna
Resolved
A fix has been deployed and the system is working again. We apologize for the inconvenience.
Posted 9 days ago. Aug 12, 2019 - 12:24 CEST
Investigating
Due to technical issues on our chant vendor's side (FreshChat), US customers might receive slower responses or an error message.
Posted 9 days ago. Aug 12, 2019 - 12:16 CEST