Settlements App unavailable for merchants in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 17:35 CEST
Investigating
Merchants in the EU are currently unable to access the Settlements App within the Merchant Portal. We are working to restore access as soon as possible and apologize for any inconvenience caused in the meantime.
Posted Oct 13, 2020 - 16:47 CEST
This incident affected: Merchant Portal.