Issues with Merchant Portal EU in the Playground environment
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 9 days ago. Feb 06, 2019 - 22:18 CET
Investigating
Merchant Portal EU in the Playground environment is currently unavailable. We are investigating this issue.
Posted 9 days ago. Feb 06, 2019 - 20:45 CET