Problems with Card services in EU
Incident Report for Klarna
Resolved
This incident is now resolved.
Posted May 13, 2020 - 19:02 CEST
Identified
Due to an ongoing issue for our card service provider consumers are currently unable to create new cards or read card details. They are aware of the issue and working on a fix. We apologize for any inconvenience caused in the meantime.
Posted May 13, 2020 - 12:49 CEST
This incident affected: Klarna Card.