Possible delays to DACH direct debits
Incident Report for Klarna
Resolved
We have identified and resolved the cause of this incident. Consumers in the DACH region with monthly direct debits due this week should expect them to be transferred within the next two days.
Posted Jun 17, 2020 - 16:25 CEST
Update
We are continuing to investigate this issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Jun 17, 2020 - 13:55 CEST
Investigating
Consumers in the DACH region who pay on a monthly direct debit basis may see delays to their payment transfers. We will provide further updates in due course.
Posted Jun 17, 2020 - 11:58 CEST