10% of Consumers in the US are currently unable to create a one time card
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 27, 2022 - 04:08 CEST
Investigating
10% of Consumers in the US are not able to create a one time card. A retry of the operation may succeed. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 27, 2022 - 03:14 CEST