Post purchase payments is experiencing degradation since 15:30 CEST
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 16:36 CEST
Investigating
Consumers may experience problems processing outstanding post purchase payments. Our engineering teams have been alerted and are actively investigating. We will update as soon as we have more information
Posted Sep 23, 2021 - 15:49 CEST