Currently <15% of consumers in Finland might be declined from purchasing due to an issue with credit assessments
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 00:32 CEST
Investigating
Since 23:03 CEST today 2021-07-19 we have been experiencing issues with receiving credit assessments from our main lookup bureau. We are currently routing the filed requests to our backup bureau. This might result in a higher number of consumers being declined credit than we would ordinarily expect. This may be reflected in a lower conversion rate for merchants.
Posted Jul 19, 2021 - 23:45 CEST