Issues with merchant email system in the US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 31, 2019 - 11:10 CET
Investigating
Currently there are issues with Klarna’s merchant support Email system in the US. We’re investigating the cause of this issue.
Posted 3 months ago. Jan 30, 2019 - 23:05 CET