Merchant Portal degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 25, 2022 - 10:08 CEST
Investigating
We are currently experiencing a degradation of the Merchant Portal. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Oct 25, 2022 - 10:05 CEST
This incident affected: Merchant Operations (Europe).