Delay to new order notifications
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 11:37 CET
Investigating
Merchants will experience a delay receiving notifications regarding new orders placed through Klarna. Pending orders will be propagated automatically upon resolution of this incident. We apologize for the inconvenience caused during this time.
Posted Nov 24, 2020 - 11:19 CET