We are currently experiencing a major outage Sofort Direct Bank Transfer
Incident Report for Klarna
Resolved
The issue has now been resolved.
Posted Sep 10, 2020 - 05:51 CEST
Investigating
We are currently seeing an outage to Sofort services affecting Direct Bank Transfer. We are currently investigating the issue and apologize for the inconvenience caused.
Posted Sep 10, 2020 - 04:54 CEST
This incident affected: SOFORT.