KCO is experiencing issues with card payments in US
Incident Report for Klarna
Resolved
The fix has been deployed and this incident is resolved.
Posted Mar 31, 2020 - 18:13 CEST
Investigating
There is currently an issue with Klara Checkout (KCO) which causes problems for customers attempting US Card Payments via KCO. A fix is already on it's way, but we apologize for any inconvenience caused.
Posted Mar 31, 2020 - 17:29 CEST