Issues with the Klarna Card signup in Germany
Incident Report for Klarna
Resolved
We are back to normal, the incident is resolved.
Posted Nov 05, 2019 - 10:36 CET
Update
We are continuing to investigate this issue.
Posted Nov 05, 2019 - 10:35 CET
Update
The Klarna Card sign-up is enabled again but a decreased performance might still be visible. Out engineers are still working on a thorough solution.
Posted Nov 05, 2019 - 08:52 CET
Update
The card sign-up has partially been re-enabled via ads but it's still unreachable via Klarna app. We will provide you with further information as soon as we can.
Posted Oct 28, 2019 - 13:35 CET
Update
Our engineers are still investigation the incident. We apologize again for your inconveniences.
Posted Oct 23, 2019 - 10:16 CEST
Update
The incident is still under investigation but we will send further information as soon as we can.
Posted Oct 22, 2019 - 14:16 CEST
Investigating
Customers in Germany are currently experiencing difficulties to sign up for a Klarna Card. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Oct 22, 2019 - 12:14 CEST
This incident affected: Klarna Card.