Delayed CHF payouts for merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 16, 2021 - 14:36 CEST
Identified
Merchants who receive payouts in Swiss Franc (CHF) might experience one bank day delay to their payouts. We apologize for the delay and thank you for your patience.
Posted Jul 16, 2021 - 14:24 CEST
This incident affected: Merchant Payouts.