Reduced acceptance rate in Norway
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Dec 06, 2020 - 22:42 CET
Investigating
Some Norwegian consumers might not be able to place orders using Klarna due to a technical issue with an external bureau. We are contacting the external party and hope to have the matter resolved soonest.
Posted Dec 06, 2020 - 21:47 CET