Consumers in the EU might not be able to sign up for Klarna Card
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for any inconvenience this caused.
Posted Dec 15, 2020 - 21:39 CET
Investigating
Consumers in the EU might not be able to sign up for a Klarna Card. We are currently investigating the issue and we apologize for the inconvenience caused.
Posted Dec 15, 2020 - 13:24 CET
This incident affected: Klarna Card.