Card payments degradation in Germany
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 07, 2022 - 11:40 CET
Identified
We have identified the issue and are working on mitigation.
Posted Nov 07, 2022 - 11:30 CET
Investigating
We are currently having issues with Klarna Card and Debit Card payments in Germany. We are investigating.
Posted Nov 07, 2022 - 11:23 CET
This incident affected: Klarna Card (Europe).