We are experiencing disturbances with the system, affecting My Klarna.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 26, 2017 - 10:31 CET
Investigating
We are experiencing disturbances with the system, affecting My Klarna. We are investigating and will come back with more information.
Posted 8 months ago. Jan 26, 2017 - 10:16 CET