Delay in automated merchant and partner onboarding processes
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 27, 2019 - 08:11 CEST
Investigating
We are currently experiencing delays in our automated merchant onboarding processes, including partner onboarding and klarna.com self-service. Our engineers are are working on resolving the issue and we apologise for the inconvenience.
Posted 22 days ago. Aug 26, 2019 - 15:40 CEST
This incident affected: Merchant Integration Tools.