Klarna.com website is down
Incident Report for Klarna
Resolved
The websites have been back up since 11:53 CET. The incident is resolved.
Posted Mar 18, 2020 - 13:18 CET
Investigating
The klarna.com website is currently down for all regions. Our engineers are already investigating.
We will provide further information as soon as we can and apologize for every inconvenience.
Posted Mar 18, 2020 - 10:03 CET