We are making changes to Klarna Statuspage which will affect your subscription settings
Incident Report for Klarna
Resolved
Update is completed. Please review and update your subscription settings.
Posted Nov 16, 2021 - 10:04 CET
Investigating
To better convey the status of Klarna’s products and services, the list of components at the top of this page is about to be replaced by a new list divided into regions. This change will be gradually rolled out in the next hour. Please review and update your subscription settings after 11:00 (CET).
Posted Nov 16, 2021 - 09:38 CET