Due to technical issues it can be difficult to reach our customer/merchant service by chat
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the disruption.
Posted Feb 24, 2021 - 15:14 CET
Investigating
We are working on solving this issue as soon as possible and apologize for any inconvenience caused in the meantime. We kindly request that you contact us through the phone instead.
Posted Feb 24, 2021 - 13:13 CET