Incoming calls cutting out
Incident Report for Klarna
Resolved
The provider have found and fixed the issue and everything is back to normal.
Posted 2 months ago. Jul 07, 2017 - 12:53 CEST
Investigating
We are currently experiencing problems with incoming calls. The provider is currently investigating the issue.
Posted 2 months ago. Jul 07, 2017 - 11:44 CEST