Klarna App degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 17:04 CET
Investigating
We are currently experiencing a ~85% degradation of term loan payment plan in Klarna App in the US since 15:07 CET. Customers might not be able to pay their debts currently or see their payment plans. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jan 10, 2022 - 16:00 CET
This incident affected: Klarna App (North America).