Issues with seeing, managing and paying with your bankaccount for US customers
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 01, 2019 - 15:13 CEST
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Apr 01, 2019 - 14:31 CEST
This incident affected: Klarna App.