Customers in EU cannot see the their orders in the klarna app
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 11:39 CEST
Investigating
We are currently experiencing issues and are working on mitigations. We apologize for the inconvenience this is causing.
Posted Jul 30, 2021 - 11:27 CEST