Merchant Portal in EU login unavailable or slow
Incident Report for Klarna
Resolved
This has now been resolved.
Posted 25 days ago. Aug 23, 2019 - 09:00 CEST
Investigating
Merchant Portal in EU is currently experiencing issues. Logging in might be slow or not work at all. Our engineers are working on resolving the issue. We apologise for the disturbance and will update as soon as we have new information.
Posted 25 days ago. Aug 23, 2019 - 08:35 CEST
This incident affected: Merchant Portal.