Direct Bank Transfer problems in Finland and Sweden
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 26, 2020 - 11:41 CEST
Update
The following updates pertain to this incident:

* Affected consumers are contacted and refund is initiated by Klarna.
* Few payments bounced back and our engineers are further investigating the same.

We will share our next update at 27Th May 15:00CET. We thank you for your patience and apologize for the inconvenience caused.
Posted May 26, 2020 - 11:10 CEST
Update
Swedish customers might be affected by the same issue.
Posted May 13, 2020 - 03:44 CEST
Update
We are still working on the issue. Further information will be published as soon as possible.
Posted May 07, 2020 - 16:57 CEST
Identified
The issue has been identified and we are working on a proposed fix.
Posted May 07, 2020 - 13:58 CEST
Investigating
Consumers in Finland are currently experiencing problems where they pay for an order but it is not matched in our system so they don't receive the product. We apologize for this and are working to have a solution as soon as possible.
Posted May 07, 2020 - 10:56 CEST
This incident affected: SOFORT.