Klarna Card and One-time card services are degraded in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 06, 2021 - 14:05 CEST
Investigating
Consumers in the EU might not be able to create a Klarna card or a one-time card due to issues at 3rd party provider.
Posted Sep 06, 2021 - 11:56 CEST
This incident affected: Klarna Card.