Users unable to log in to Klarna App using email link due to third party outage
Incident Report for Klarna
Resolved
The issue has been fixed on Klarna's side since 16:16 CEST.
Posted Jul 28, 2020 - 17:18 CEST
Investigating
Our email provider SendGrid is currently experiencing an outage which causes Klarna App users to not be able to log in using email link. More information can be found on the provider's status page here: https://status.sendgrid.com/.
Posted Jul 28, 2020 - 16:28 CEST
This incident affected: Klarna App.