We are currently experiencing issues with Sofort payments in the EU
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the disruption.
Posted Feb 24, 2021 - 10:40 CET
Update
Current issues are regarding Direct Bank Transfer for KP (and not all payment methods). We apologize for the inconvenience.
Posted Feb 24, 2021 - 10:29 CET
Update
We don’t see any more impact on Sofort classic payments. We are still experiencing issues with KP direct bank transfer.
Posted Feb 24, 2021 - 09:51 CET
Update
We don’t see any more impact on KCO payments.
Posted Feb 24, 2021 - 09:45 CET
Investigating
This also affects the direct bank transfers of KCO and KP. We apologize for the inconvenience.
Posted Feb 24, 2021 - 09:38 CET