We're currently seeing degraded performance of our payment methods in the US
Incident Report for Klarna
Resolved
This incident has been resolved. This had an impact on all Klarna payments, not only saved cards. We apologise for any inconvenience caused.
Posted Mar 31, 2021 - 12:46 CEST
Monitoring
We are seeing recovery and are currently monitoring the situation.
Posted Mar 31, 2021 - 12:35 CEST
Identified
Customers with stored cards on both Pay in 4 and Term Loan financing are not able to proceed purchases in the US. Our engineering teams are actively working on a fix.
Posted Mar 31, 2021 - 12:30 CEST