Nordea Finland interface disabled
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 16:25 CET
Investigating
We have identified technical issues with the PSD2 connection towards Nordea in Finland. We have deactivated the access to the bank until the bank has fixed the issues on their side.
Posted Nov 16, 2021 - 11:06 CET
This incident affected: Open Banking (Europe).