Customers in the EU cannot create/update physical & virtual cards or retrieve card information due to a 3rd party issue.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 18, 2022 - 00:23 CET
Identified
3rd Party has identified an issue with their service and will provide updates as the incident continues.
Posted Jan 17, 2022 - 23:37 CET
Investigating
We are currently investigating this issue.
Posted Jan 17, 2022 - 23:20 CET
This incident affected: Klarna Card (Europe).