Payments are failing with ABN AMRO bank in Netherlands through iDEAL
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 17, 2022 - 17:51 CEST
Investigating
We have noticed an issue with iDeal payments with ABN AMRO. We are currently monitoring.
Posted Jul 17, 2022 - 16:40 CEST