We are currently experiencing issues with external credit service in Norway
Incident Report for Klarna
Resolved
This incident has been resolved. The incident impacted in total <14% of the requests between 08:29 - 10:45 a.m. CEST. We apologize for any inconvenience caused.
Posted Oct 17, 2021 - 11:03 CEST
Update
Payment method Pay Later and Slice It has degradation for ~16% of the customers. We are continuing to investigate this issue.
Posted Oct 17, 2021 - 10:20 CEST
Investigating
The issue impacts consumers' ability to place purchases in Norway with Pay Later and Slice It. The issue has started at 08:29 a.m. CET. We are currently investigating this issue and apologize for any inconvenience caused.
Posted Oct 17, 2021 - 10:05 CEST