Klarna Bank Account and Card degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 11:44 CEST
Investigating
We are currently experiencing issues with Klarna Bank Account and Klarna Card. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 01, 2022 - 09:24 CEST
This incident affected: Klarna Bank Account (Europe) and Klarna Card (Europe).