Issue with handling payments and mandates in the UK
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 24 days ago. Jun 27, 2019 - 15:00 CEST
Investigating
One of our providers in the UK, named GoCardless, is down. So, it is currently not possible to sign up for mandates, initiate payments or refunds in the UK. We are working on it and we will provide you with further information as soon as possible.
Posted 24 days ago. Jun 27, 2019 - 14:24 CEST
This incident affected: Klarna App.