Customers may experience chat delays in the EU region
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 03:45 CEST
Update
We are continuing to investigate this issue.
Posted Sep 17, 2021 - 03:14 CEST
Investigating
Due to technical issues, it may be difficult for a subset of consumers to reach our customer service by chat. We are working on solving this issue as soon as possible and apologize for any inconvenience caused in the meantime. We kindly request that you contact us through the phone instead.
Posted Sep 17, 2021 - 02:01 CEST